hi
i want to use skystar2.8 in 'linux fedora core 7' but it dosn't work!
i ran the following command in the terminal:
code:
Code:
[[email protected] ~]# uname -r
2.6.21-1.3194.fc7.stk16
[[email protected] ~]# dmesg | grep flexcop
b2c2-flexcop: B2C2 FlexcopII/II(b)/III digital TV receiver chip loaded successfully
flexcop-pci: will use the HW PID filter.
flexcop-pci: card revision 2
b2c2-flexcop: MAC address = 00:09:c8:a0:31:6b
b2c2-flexcop: i2c master_xfer failed
b2c2-flexcop: i2c master_xfer failed
b2c2-flexcop: i2c master_xfer failed
b2c2-flexcop: i2c master_xfer failed
b2c2-flexcop: i2c master_xfer failed
b2c2-flexcop: i2c master_xfer failed
b2c2-flexcop: i2c master_xfer failed
b2c2-flexcop: i2c master_xfer failed
b2c2-flexcop: no frontend driver found for this B2C2/FlexCop adapter
[[email protected] ~]# lsmod | grep flexcop
b2c2_flexcop_pci       12505  0 
b2c2_flexcop           29645  1 b2c2_flexcop_pci
dvb_core               77801  3 lgdt330x,stv0299,b2c2_flexcop
dvb_pll                18245  1 b2c2_flexcop
i2c_core               24641  12 mt312,stv0297,bcm3510,lgdt330x,nxt200x,mt352,stv0299,i2c_savage4,b2c2_flexcop,i2c_algo_bit,i2c_piix4,dvb_pll
[[email protected] ~]#
but i didn't know what was the problem.then i did these:
(refrence:http://www.linuxquestions.org/linux/answers/Hardware)
$ sh dvd.sh
codes for dvd.sh:
Code:
#!/bin/sh
# Create device nodes for the Linux DVB API with DVB_API_VERSION 2.
# The devices created are suitable for most current PC DVB cards,
# i.e. cards having one frontend, one demux and optionally one
# MPEG decoder.
# The script creates devices for four cards by default.

if [ -e /dev/.devfsd ]; then
echo "It seems you are using devfs. Good!"
exit 0
fi

# get rid of old DVB API devices; do it twice for good measure...
rm -rf /dev/ost
rm -rf /dev/ost
rm -rf /dev/dvb
rm -rf /dev/dvb

mkdir /dev/dvb
chmod 755 /dev/dvb

for i in `seq 0 3`; do
echo "Creating DVB devices in /dev/dvb/adapter$i"
mkdir /dev/dvb/adapter$i
chmod 755 /dev/dvb/adapter$i
mknod -m 0600 /dev/dvb/adapter$i/video0 c 212 `expr 64 \* $i + 0`
mknod -m 0600 /dev/dvb/adapter$i/audio0 c 212 `expr 64 \* $i + 1`
mknod -m 0600 /dev/dvb/adapter$i/frontend0 c 212 `expr 64 \* $i + 3`
mknod -m 0600 /dev/dvb/adapter$i/demux0 c 212 `expr 64 \* $i + 4`
mknod -m 0600 /dev/dvb/adapter$i/dvr0 c 212 `expr 64 \* $i + 5`
mknod -m 0600 /dev/dvb/adapter$i/ca0 c 212 `expr 64 \* $i + 6`
mknod -m 0600 /dev/dvb/adapter$i/net0 c 212 `expr 64 \* $i + 7`
mknod -m 0600 /dev/dvb/adapter$i/osd0 c 212 `expr 64 \* $i + 8`
chown root.video /dev/dvb/adapter$i/*
done
then i download "linuxtv-dvb-apps-1.1.1" and make it.
but when i tune dvb whith szap in terminal :
Code:
[[email protected] szap]# ./szap -c channels.conf-dvbs-Hotbird Mediatel
reading channels from file 'channels.conf-dvbs-Hotbird'
zapping to 1 'Mediatel':
sat 0, frequency = 10949 MHz V, symbolrate 27500000, vpid = 0x1389, apid = 0x1393
using '/dev/dvb/adapter0/frontend0' and '/dev/dvb/adapter0/demux0'
opening frontend failed: No such device
[[email protected] szap]#
please help me!
thanks a lot