Register

Welcome to the RDI-Board Community.

If this is your first visit, be sure to check out the FAQ by clicking the link above. You may have to register before you can post: click the register link above to proceed.


Donate Now Goal amount for this month: 100 EUR, Received: 100 EUR (100%)
Donate to support this site...

Page 1 of 2 12 LastLast
Results 1 to 15 of 18
  1. #1
    Digitally Remastered Expert
    Join Date
    Feb 2005
    Location
    root
    Posts
    1,527
    Posts Thanks / Likes

    Default WinXP GBX Server + Phoenix

    Hai să mai schimbăm puţin "subiectul zilei"...

    Vreau să fac un server GBX sub windozxp la care să leg o interfaţă Phoenix. Fireşte că doar n scop didactic.
    Porturile sunt deschise din router, ioperm lucrează, GBXu' porneşte, dar la un moment dat, după Hello1 ... şi Hello2 ..., apare:

    ...
    ->Here? to my DNS (my IP)
    **** hashTable ECM 0 elements ****
    **** hashTable EMM 0 elements ****
    ReRead pmt.tmp
    **** hashTable ECM 0 elements ****
    **** hashTable EMM 0 elements ****
    ->Here? to my DNS (my IP)
    ->Here? to my DNS (my IP)
    ...

    ... şi tot aşa mai departe Here? to n continuare, la nesfrşit şi sunt forţat să opresc procesul.

    Are cineva idee care poate fi cauza?
    mi poate da cineva cteva hint-uri referitor la legarea interfeţei Phoenix la acest server? Cardul de test ar fi un dreamcrypt, dar nu e obligatoriu.
    [LEFT]Signature not found... Try again!

  2. #2
    Senior Member Expert
    Join Date
    Jan 2005
    Posts
    1,781
    Posts Thanks / Likes

    Default

    daca vrei cautama pe yahoo si am sa te ajut ...



    Antes de postear en este foro, lea las normas y presntese. Y al presentarse respete las normas N 1. Gracias

    NORMAS: http://www.rdi-board.com/showthread.php?t=59064

  3. #3
    cel mai frumos Mentor
    Join Date
    Apr 2004
    Location
    Cluj-Napoca
    Posts
    831
    Posts Thanks / Likes

    Default

    Firewallu de windows? ai forward porturile? era un tutorial pe aici foarte bun despre gbox si windows...poate il mai are careva

  4. #4
    Gold Member Expert
    RDI - Board Default Avatar

    Join Date
    Sep 2005
    Location
    Tr. Severin
    Posts
    3,273
    Posts Thanks / Likes

    Default

    Quote Originally Posted by chooleen View Post
    ->Here? to my DNS (my IP)
    **** hashTable ECM 0 elements ****
    **** hashTable EMM 0 elements ****
    ReRead pmt.tmp
    Are cineva idee care poate fi cauza?
    asa face la mine cind nu are cu cine palavragi

  5. #5
    Digitally Remastered Expert
    Join Date
    Feb 2005
    Location
    root
    Posts
    1,527
    Posts Thanks / Likes

    Default

    Quote Originally Posted by obywans View Post
    daca vrei cautama pe yahoo si am sa te ajut ...
    Eşti n listă! Gracias!

    Quote Originally Posted by buleus View Post
    Firewallu de windows? ai forward porturile? era un tutorial pe aici foarte bun despre gbox si windows...poate il mai are careva
    Parcă văzusem şi eu odată ceva, dar nu l-am mai găsit. Oricum era ceva "subţire" din cte mi amintesc.
    Porturile sunt OK. No firewall.
    [LEFT]Signature not found... Try again!

  6. #6
    Digitally Remastered Expert
    Join Date
    Feb 2005
    Location
    root
    Posts
    1,527
    Posts Thanks / Likes

    Default

    Quote Originally Posted by smv167 View Post
    asa face la mine cind nu are cu cine palavragi
    Poi, orijinelu nu tace.
    [LEFT]Signature not found... Try again!

  7. #7
    Member Mentor
    Join Date
    Dec 2003
    Location
    in canal,langa aurolaci
    Posts
    664
    Posts Thanks / Likes

    Default

    un tutorial facut de mine mai demult si postat pe forumul nabilo

    Decompress the archive in attachment to some PC directory
    You must have the Cygwin Packet installed before gbox can recognize
    any device attached to its com ports ,so go to http://www.cygwin.com/
    and u will see there an option "Install or update now!" which u have to click
    u shall leave all the default options and wait for him to finish the install
    (aprox.3-4 minutes)
    after this it will create a C:\cygwin\ directory and a shortcut on desktop
    You must copy from the attachment these 2 files ioperm.exe and ioperm.sys to
    C:\cygwin\bin
    double click now on the cygwin shortcut on the desktop and type there ioperm -i
    things are all done by now and you should be able to run gboxx86.exe from the
    directory u had decompressed the included archive;
    if phoenix its connected u should see this message right after double-clicking gboxx86.exe :

    gbox 2.25/Windows&[email protected] ( Jun 06 2006, 06:04:00 )
    OSD (dbox2) IP = 192.168.0.xxx
    Seasonport=0 speed=9600
    mode 03
    AU:02/update:01/KeyFile:01 Hash:01 DispECM:02/EMM:02 UDPInit:00 OSD:00
    Total 44 EMM kekse read from nagra.txt
    My IP 192.168.000.xxx ID xxxx (192.168.0.xxx) pass xxxxxxxx, we are online
    IP 192.168.000.xxx Port xxxx-xxxx ID xxxx pass xxxxxxxx sharelevel 5/5 (192.168.
    0.xxx)
    enx_conf = 0 ; reset on zap=0
    Total 1 ports to monitor
    monitoring port: xxxx
    CPU 80X86 compatible
    TPSCrypt 1 PTS 1/1
    strange input data in gbox_cfg, Frequency, filepos 3380
    /dev/ttyS0 opened with 1 multicam(s)
    mode: any pid
    have to init card 3
    ATR :
    xx xx xx xx xx xx xx xx xx xx xx xx xx xx xx xx xx xx xx xx

    Reset Baudrate = 9600 Baud
    cardsystem= 1
    HexSerial : xx xx xx
    Provider00 FF FF FF
    Provider10 FF FF FF
    CaID 1 : 00 00
    CaID 2 : 17 02
    CaID 3 : 00 00
    CaID 4 : 00 00
    chid: 03DE 18.05.2005-05.10.2006 card active
    chid: 7D27 18.05.2005-05.10.2006 Beate Uhse
    chid: 7D21 18.05.2005-05.10.2006 Plus
    chid: 7D2B 18.05.2005-05.10.2006 PW Start
    chid: 7D23 18.05.2005-05.10.2006 Sport
    chid: 03F2 18.05.2005-05.10.2006 Goldstar TV
    chid: 7D22 18.05.2005-05.10.2006 PW Film
    Version: xxxxxxxx Revxxx
    xxxxx
    Camkey OK - 2788 ms
    Working Baudrate = 9600 Baud
    card init ok
    entering main loop
    ReRead pmt.tmp
    ->HelloL to 192.168.0.xxx (192.168.000.xxxxxx)
    ReRead pmt.tmp
    ReRead pmt.tmp
    <-Hello from 192.168.0.xxx port xxxx
    <=Hello from 192.168.0.xxx port xxxx
    <=Hello from 192.168.0.xxx port xxxx
    **** hashTableECM 0 elements ****
    **** hashTableEMM 0 elements ****
    ReRead pmt.tmp
    ->HelloL to 192.168.0.xxx (192.168.000.xxxxxx)

    p.s of course,place your own cwshare.cfg and ignore.list in directory


    http://rapidshare.com/files/10823242...erver.rar.html

    Living an analog lifestyle in a digital world

  8. #8
    Digitally Remastered Expert
    Join Date
    Feb 2005
    Location
    root
    Posts
    1,527
    Posts Thanks / Likes

    Default

    Merci @marcelll
    Cam ce ai postat tu am făcut şi eu, cu mica diferenţă că executabilul meu era 2.0. Serverul porneşte, dar la Hello o ia n barbă. Am mai ncercat şi cu 2.1b şi cu 2.25 ăla de la tine, dar rezultatul a fost acelaşi. Mă gndesc să nu fie din ceva setări de la cfg. Am să mai fac săpături.
    [LEFT]Signature not found... Try again!

  9. #9
    Junior Member Teacher
    Join Date
    Jun 2007
    Location
    26.12E / 44.42N
    Posts
    473
    Posts Thanks / Likes

    Lightbulb

    Quote Originally Posted by chooleen View Post
    mi poate da cineva cteva hint-uri referitor la legarea interfeţei Phoenix la acest server? Cardul de test ar fi un dreamcrypt, dar nu e obligatoriu.
    m-am confruntat si eu de curind cu setarea unui phoenix pe pc si pot spune ca n-a fost usor
    foarte greu am descoperit ca linia V: pentru com-ul 1 al pc-ului trebuie sa arate asa V: { 00 05 }
    setarea am gasit-o intr-o arhiva ce "garanta" functionarea cu phoenix

  10. #10
    Digitally Remastered Expert
    Join Date
    Feb 2005
    Location
    root
    Posts
    1,527
    Posts Thanks / Likes

    Default

    Configul pe care l folosesc arată aşa:
    Code:
    Z: { 01 12 } 192.168.10.1 8021
    G: { 03 }
    C: { 02 }
    M: { 02 }
    A: { 02 }
    U: { 01 }
    H: { 01 }
    T: { 01 }
    O: { 00 } 192.168.10.1
    L: { 00 } 192.168.10.1 8017
    #R: { 01 }
    W: { 00 00 } 9600
    V: { 00 05 }
    După cum vezi, V-ul e identic.

    La rulare am parte de asta:



    Acel Here? to apare la nesfrşit, fiind forţat să l opresc cu ctrl+c.

    Prima problemă ar fi că serverul nu merge cum trebuie şi nu-mi dau seama care setare ar fi cauza.
    A doua problemă ar fi cardul din Phoenix, care (după cum se vede n screenshot) dă rateu la iniţializare. Pentru dreamcrypt este nevoie de niscaiva setări speciale?

    [LEFT]Signature not found... Try again!

  11. #11
    Member Mentor
    Join Date
    Mar 2003
    Location
    Romania
    Posts
    857
    Posts Thanks / Likes

    Default

    Din poza se vede clar ca nu primeste raspuns de la peer-uri si tot trimite cereri. Nu cred ca este o problema de configurare a gbox mai degraba ai ceva firewall activ care blocheaza cererile sau e o problema de forward-are a portului utilizat (daca ai router).
    Eventual poti sa-l intrebi pe careva dintre peer-uri daca ajung cererile la el.

  12. #12
    Trnacopist Expert
    Join Date
    Dec 2005
    Location
    /home/satwien/
    Posts
    6,001
    Posts Thanks / Likes

    Default

    1. Sterge fisierul [email protected]@.txt si altele de acelasi tip;
    2. Scoare cardul din phoenix;
    3. Incearca sa fortezi alte baudrate;

    IN softcam incearca asta:

    T: { 00 02 01 } ATR timeout (normal*X), instruction timeout (normal*X)
    T: { 01 00000 000 } lrdeto: byte delay (1e-6 s), instruction delay (1e-3 s)
    T: { 02 00000 000 } Seca
    T: { 03 00000 000 } Viaccess
    T: { 04 00000 030 } [email protected]
    T: { 05 00000 000 } CryptoWorks
    T: { 06 00000 000 } Geldkarte
    T: { 07 00000 000 } Conax
    T: { 08 00000 000 } NDS
    Am presupus ca ai un card [email protected] in phoenix, daca e de alt tip, modifica tu corespunzator dupa modelul de mai sus.

  13. #13
    Digitally Remastered Expert
    Join Date
    Feb 2005
    Location
    root
    Posts
    1,527
    Posts Thanks / Likes

    Default

    Quote Originally Posted by bbox View Post
    Din poza se vede clar ca nu primeste raspuns de la peer-uri si tot trimite cereri. Nu cred ca este o problema de configurare a gbox mai degraba ai ceva firewall activ care blocheaza cererile sau e o problema de forward-are a portului utilizat (daca ai router).
    Eventual poti sa-l intrebi pe careva dintre peer-uri daca ajung cererile la el.
    Firewall-ul este OFF. n router am forwardat 2 porturi către PC şi le-am folosit pe rnd, dar fără succes. Am creat şi un DNS la no-ip.org, dar nu vrea să plece deloc. Nici dacă folosesc DNS, nici dacă folosesc IP şi nici dacă le combin. De aceea m-am gndit că s-ar putea să fie vorba de nişte setări din fişierele de configurare. Partajarea se face doar ntre PC şi DM500, acestea fiind la 5 metri distanţă. Nu sunt implicate peer-uri externe.

    Quote Originally Posted by SatWien View Post
    1. Sterge fisierul [email protected]@.txt si altele de acelasi tip;
    2. Scoare cardul din phoenix;
    3. Incearca sa fortezi alte baudrate;

    IN softcam incearca asta: ...

    Am presupus ca ai un card [email protected] in phoenix, daca e de alt tip, modifica tu corespunzator dupa modelul de mai sus.
    Problema cu Phoenix-ul este una adiacentă. Chiar dacă nu-l folosesc, serverul ar trebui să meargă, dar nu se ntmplă aşa. Ceva similar cu acele linii T am şi eu n softcam.cfg. Cardul este un dreamcrypt (INXTC) şi n-am idee ce linie T i s-ar cuveni. Nici n-am chef să fac teste pe alt card. Am ncercat să modific n gb0x_cfg linia W: { 00 00 } 9600 cu W: { 00 00 } 38400, valoare ce apărea n log, dar nu se ntmplă nimic. Eu am bănuit că de acolo se modifică baudrate.
    Fişierele [email protected], [email protected], etc. n-au nici o influenţă. Dacă nu există, notifică acest fapt, dar n rest, aceeaşi mişcare.
    [LEFT]Signature not found... Try again!

  14. #14
    Digitally Remastered Expert
    Join Date
    Feb 2005
    Location
    root
    Posts
    1,527
    Posts Thanks / Likes

    Default

    Eu centrez, eu dau cu capul.

    Pentru iniţializarea cardului dreamcrypt/FireCrypt n Phoenix se pune n softcam.cfg liniaurmătoare:

    T: { 09 01000 030 } Dreamcrypt.

    Acel 9 este cardsistem-ul afişat pe consolă.
    Code:
    /dev/ttyS0 opened with 1 multicam(s)
    mode: any pid
    have to init card 3
    ATR : 
    3B 9C 13 11 81 64 72 65 61 6D 63 72 79 70 74 00 
    04 08 
    Reset Baudrate = 9600 Baud
    cardsystem= 9
    Dreamcrypt card
    CA system: 00 04 
    Provider : 00 00 02 
    Serial_a : FD F6 60 
    Serial_b : EF 96 50 
    caid : 4A 70 
    camcrypt : TEA Mode
    Working Baudrate = 38400 Baud
    card init ok
    entering main loop
    Deci partea asta am rezolvat-o.
    Rămne de pus pe picioare serverul.
    [LEFT]Signature not found... Try again!

  15. #15
    Member Mentor
    Join Date
    Mar 2003
    Location
    Romania
    Posts
    857
    Posts Thanks / Likes

    Default

    Quote Originally Posted by chooleen View Post
    Nici dacă folosesc DNS, nici dacă folosesc IP şi nici dacă le combin. De aceea m-am gndit că s-ar putea să fie vorba de nişte setări din fişierele de configurare. Partajarea se face doar ntre PC şi DM500, acestea fiind la 5 metri distanţă. Nu sunt implicate peer-uri externe.
    Sa inteleg ca DM si PC sunt legate la un router si au IP-uri interne din aceeasi clasa?
    In acest caz poti sa folosesti numai IP-urile interne, nu te mai complica cu nume DNS. Nu trebuie sa forward-ezi porturi in router.
    Pe DM500 pui o linie D cu IP-ul intern de la PC si pe PC pui linie M cu IP intern PC si D cu IP intern de la DM500.
    Asa este la mine si merge perfect.
    Daca tot nu merge, incearca sa comentezi linia D corespunzatoare PC-ului de pe DM500 si vezi daca apar atacuri (numai sa nu fie dezactivate), poate te ajuta mesajul de la atac.

 

 

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Back to Top